const regex = new RegExp('(?:(?:\\s+(?:and|or|if)\\s+)|"[^"]+")(*SKIP)(*FAIL)|\\s+', 'gm')
const str = `
lorem and ipsum or other ipsum
if not sid amet then lorem ipsum again
"let me completely alone"
some fantastic whitespaces all over here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}