$re = '~(?:(?:\s+(?:and|or|if)\s+)|"[^"]+")(*SKIP)(*FAIL)|\s+~m';
$str = '
lorem and ipsum or other ipsum
if not sid amet then lorem ipsum again
"let me completely alone"
some fantastic whitespaces all over here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);