#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\/post\b)(?:\/[\w]+){2}$"
Local $sString = "/post/1" & @CRLF & _
"/post/5/" & @CRLF & _
"/post/6/comments/4" & @CRLF & _
"/post/6/comments" & @CRLF & _
"/post/a-random-slug"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")