$re = '/^(?:\/post\b)(?:\/[\w]+){2}$/m';
$str = '/post/1
/post/5/
/post/6/comments/4
/post/6/comments
/post/a-random-slug';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);