import re
regex = re.compile(r"^(?:\/post\b)(?:\/[\w]+){2}$", flags=re.MULTILINE)
test_str = ("/post/1\n"
"/post/5/\n"
"/post/6/comments/4\n"
"/post/6/comments\n"
"/post/a-random-slug")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")