using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\/post\b)(?:\/[\w]+){2}$";
string input = @"/post/1
/post/5/
/post/6/comments/4
/post/6/comments
/post/a-random-slug";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}