re = /^(?:\/post\b)(?:\/[\w]+){2}$/m
str = '/post/1
/post/5/
/post/6/comments/4
/post/6/comments
/post/a-random-slug'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end