const regex = new RegExp('(\\d+.*?)engineer', 'mig')
const str = `abc mysql 23 rufos kanso engineer
def grusol defno 1635 minos kalopo, ruso engineer okas puno"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}