re = /(\d+.*?)engineer/mi
str = 'abc mysql 23 rufos kanso engineer
def grusol defno 1635 minos kalopo, ruso engineer okas puno"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end