$re = '/(\d+.*?)engineer/mi';
$str = 'abc mysql 23 rufos kanso engineer
def grusol defno 1635 minos kalopo, ruso engineer okas puno"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);