// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\d+.*?)engineer").unwrap();
let string = "abc mysql 23 rufos kanso engineer
def grusol defno 1635 minos kalopo, ruso engineer okas puno\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}