import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\?{3} ad-question (.+)\\n{2,}((?:(?!---).*\\n)*?)\\n+---";
final String string = "??? ad-question Quels sont les deux types de bornages ?\n\n"
+ "Il y en a deux :\n\n"
+ "- Le bornage amiable.\n\n"
+ "- Le bornage judiciaire.\n\n"
+ "test\n\n"
+ "--- admonition\n\n"
+ "test\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}