import re
regex = re.compile(r"^\?{3} ad-question (.+)\n{2,}((?:(?!---).*\n)*?)\n+---", flags=re.MULTILINE)
test_str = ("??? ad-question Quels sont les deux types de bornages ?\n\n"
"Il y en a deux :\n\n"
"- Le bornage amiable.\n\n"
"- Le bornage judiciaire.\n\n"
"test\n\n"
"--- admonition\n\n"
"test\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")