$re = '/^\?{3} ad-question (.+)\n{2,}((?:(?!---).*\n)*?)\n+---/m';
$str = '??? ad-question Quels sont les deux types de bornages ?
Il y en a deux :
- Le bornage amiable.
- Le bornage judiciaire.
test
--- admonition
test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);