re = /^\?{3} ad-question (.+)\n{2,}((?:(?!---).*\n)*?)\n+---/m
str = '??? ad-question Quels sont les deux types de bornages ?
Il y en a deux :
- Le bornage amiable.
- Le bornage judiciaire.
test
--- admonition
test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end