const regex = /^\?{3} ad-question (.+)\n{2,}((?:(?!---).*\n)*?)\n+---/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\?{3} ad-question (.+)\\n{2,}((?:(?!---).*\\n)*?)\\n+---', 'gm')
const str = `??? ad-question Quels sont les deux types de bornages ?
Il y en a deux :
- Le bornage amiable.
- Le bornage judiciaire.
test
--- admonition
test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}