# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([0-9]+)\b/0$1~01234567890/g;t' <<< "1"