$re = '/\b([0-9]+)\b/';
$str = '1';
$subst = "0$1~01234567890";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;