#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0\.(?!00)|(?!0)\d+\.)\d\d$"
Local $sString = "101.00" & @CRLF & _
"110.00" & @CRLF & _
"1000.00" & @CRLF & _
"0.50" & @CRLF & _
"1.00" & @CRLF & _
"1.10" & @CRLF & _
"1.11" & @CRLF & _
"11.11" & @CRLF & _
"0.00" & @CRLF & _
"0" & @CRLF & _
"00.00" & @CRLF & _
"000.00" & @CRLF & _
"0101.00" & @CRLF & _
"01000.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")