re = /^(0\.(?!00)|(?!0)\d+\.)\d\d$/m
str = '101.00
110.00
1000.00
0.50
1.00
1.10
1.11
11.11
0.00
0
00.00
000.00
0101.00
01000.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end