const regex = /^(0\.(?!00)|(?!0)\d+\.)\d\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0\\.(?!00)|(?!0)\\d+\\.)\\d\\d$', 'gm')
const str = `101.00
110.00
1000.00
0.50
1.00
1.10
1.11
11.11
0.00
0
00.00
000.00
0101.00
01000.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}