import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0\\.(?!00)|(?!0)\\d+\\.)\\d\\d$";
final String string = "101.00\n"
+ "110.00\n"
+ "1000.00\n"
+ "0.50\n"
+ "1.00\n"
+ "1.10\n"
+ "1.11\n"
+ "11.11\n"
+ "0.00\n"
+ "0\n"
+ "00.00\n"
+ "000.00\n"
+ "0101.00\n"
+ "01000.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}