use strict;
my $str = '101.00
110.00
1000.00
0.50
1.00
1.10
1.11
11.11
0.00
0
00.00
000.00
0101.00
01000.00';
my $regex = qr/^(0\.(?!00)|(?!0)\d+\.)\d\d$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}