#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)disconnected, (?<reason>.*?)(?:\(\d+\)| -\d+)?$"
Local $sString = "disconnected, received disassoc: sending station leaving (8)" & @CRLF & _
"disconnected, 4-way handshake timeout" & @CRLF & _
"disconnected, too weak signal, signal strength -91" & @CRLF & _
"disconnected, registered to other interface"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")