using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"disconnected, (?<reason>.*?)(?:\(\d+\)| -\d+)?$";
string input = @"disconnected, received disassoc: sending station leaving (8)
disconnected, 4-way handshake timeout
disconnected, too weak signal, signal strength -91
disconnected, registered to other interface";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}