const regex = /disconnected, (?<reason>.*?)(?:\(\d+\)| -\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('disconnected, (?<reason>.*?)(?:\\(\\d+\\)| -\\d+)?$', 'gm')
const str = `disconnected, received disassoc: sending station leaving (8)
disconnected, 4-way handshake timeout
disconnected, too weak signal, signal strength -91
disconnected, registered to other interface`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}