import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "disconnected, (?<reason>.*?)(?:\\(\\d+\\)| -\\d+)?$";
final String string = "disconnected, received disassoc: sending station leaving (8)\n"
+ "disconnected, 4-way handshake timeout\n"
+ "disconnected, too weak signal, signal strength -91\n"
+ "disconnected, registered to other interface";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}