re = /disconnected, (?<reason>.*?)(?:\(\d+\)| -\d+)?$/m
str = 'disconnected, received disassoc: sending station leaving (8)
disconnected, 4-way handshake timeout
disconnected, too weak signal, signal strength -91
disconnected, registered to other interface'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end