using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+%[^.](?:(?!original\b)[^\d\r\n])*\bpercentage\b";
string input = @"In some cases, 10% of the sales starts with the original percentage --> my regex match with this string but I don't want to because it contains the word ""original""
The 10% of the sales starts with a certain percentage --> my regex match with this string, it's okay because it doesn't containt the word ""original""
The 10% of the original
percentage of the sale is higher--> my regex doesn't match with this string, and it's okay because it containts the word ""original"" (maybe because the new line starts with percentage?)
The 10% of the original sale
is the percentage of that --> my regex match with this string but I don't want to because it contains the word ""original""
10% ""whatever"" percentage
10% original percentage";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}