use strict;
my $str = 'In some cases, 10% of the sales starts with the original percentage --> my regex match with this string but I don\'t want to because it contains the word "original"
The 10% of the sales starts with a certain percentage --> my regex match with this string, it\'s okay because it doesn\'t containt the word "original"
The 10% of the original
percentage of the sale is higher--> my regex doesn\'t match with this string, and it\'s okay because it containts the word "original" (maybe because the new line starts with percentage?)
The 10% of the original sale
is the percentage of that --> my regex match with this string but I don\'t want to because it contains the word "original"
10% "whatever" percentage
10% original percentage';
my $regex = qr/\d+%[^.](?:(?!original\b)[^\d\r\n])*\bpercentage\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}