$re = '/\d+%[^.](?:(?!original\b)[^\d\r\n])*\bpercentage\b/m';
$str = 'In some cases, 10% of the sales starts with the original percentage --> my regex match with this string but I don\'t want to because it contains the word "original"
The 10% of the sales starts with a certain percentage --> my regex match with this string, it\'s okay because it doesn\'t containt the word "original"
The 10% of the original
percentage of the sale is higher--> my regex doesn\'t match with this string, and it\'s okay because it containts the word "original" (maybe because the new line starts with percentage?)
The 10% of the original sale
is the percentage of that --> my regex match with this string but I don\'t want to because it contains the word "original"
10% "whatever" percentage
10% original percentage';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);