import Foundation
let pattern = #"\d+%[^.](?:(?!original\b)[^\d\r\n])*\bpercentage\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
In some cases, 10% of the sales starts with the original percentage --> my regex match with this string but I don't want to because it contains the word "original"
The 10% of the sales starts with a certain percentage --> my regex match with this string, it's okay because it doesn't containt the word "original"
The 10% of the original
percentage of the sale is higher--> my regex doesn't match with this string, and it's okay because it containts the word "original" (maybe because the new line starts with percentage?)
The 10% of the original sale
is the percentage of that --> my regex match with this string but I don't want to because it contains the word "original"
10% "whatever" percentage
10% original percentage
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)