import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+%[^.](?:(?!original\\b)[^\\d\\r\\n])*\\bpercentage\\b";
final String string = "In some cases, 10% of the sales starts with the original percentage --> my regex match with this string but I don't want to because it contains the word \"original\"\n\n"
+ "The 10% of the sales starts with a certain percentage --> my regex match with this string, it's okay because it doesn't containt the word \"original\"\n\n"
+ "The 10% of the original\n"
+ "percentage of the sale is higher--> my regex doesn't match with this string, and it's okay because it containts the word \"original\" (maybe because the new line starts with percentage?)\n\n"
+ "The 10% of the original sale\n"
+ "is the percentage of that --> my regex match with this string but I don't want to because it contains the word \"original\"\n\n"
+ "10% \"whatever\" percentage\n\n"
+ "10% original percentage";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}