#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<.+>"
Local $sString = "Поиск тегов в тексте (жадный квантификатор):" & @CRLF & _
"" & @CRLF & _
"<phone>111-11-11</phone>" & @CRLF & _
"<phone>222-22-22</phone>" & @CRLF & _
"<phone>333-33-33</phone>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")