const regex = /<.+>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<.+>', 'gm')
const str = `Поиск тегов в тексте (жадный квантификатор):
<phone>111-11-11</phone>
<phone>222-22-22</phone>
<phone>333-33-33</phone>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}