$re = '/<.+>/m';
$str = 'Поиск тегов в тексте (жадный квантификатор):
<phone>111-11-11</phone>
<phone>222-22-22</phone>
<phone>333-33-33</phone>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);