package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<.+>`)
var str = `Поиск тегов в тексте (жадный квантификатор):
<phone>111-11-11</phone>
<phone>222-22-22</phone>
<phone>333-33-33</phone>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}