using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<.+>";
string input = @"Поиск тегов в тексте (жадный квантификатор):
<phone>111-11-11</phone>
<phone>222-22-22</phone>
<phone>333-33-33</phone>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}