# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{print\h+\K[^{}]*\R(?=}end)//gms;t' <<< "{print next
error
incorrect
err
}end"