$re = '/\{print\h+\K[^{}]*\R(?=}end)/ms';
$str = '{print next
error
incorrect
err
}end';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;