#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)\{print\h+\K[^{}]*\R(?=}end)"
Local $sString = "{print next" & @CRLF & _
"error" & @CRLF & _
"incorrect" & @CRLF & _
"err" & @CRLF & _
"}end"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)