const regex = /\{print\h+\K[^{}]*\R(?=}end)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{print\\h+\\K[^{}]*\\R(?=}end)', 'gms')
const str = `{print next
error
incorrect
err
}end`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);