re = /\{print\h+\K[^{}]*\R(?=}end)/m
str = '{print next
error
incorrect
err
}end'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result