using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=begin{DoxyCode})([\s\S]+?[^\\])([_%])([\s\S]+?)(?=end{DoxyCode})";
string input = @"\begin{DoxyCode}
17 This is some code that contains an_undersc_ore and
18 an escaped\_underscore. Plus another unescaped_unders_core
19 for good measure.
20 As if that was not ""bad"" enough, it also contains a %percent sign
21 that is unescaped.
\end{DoxyCode}
Here is some other stuff that may contain \index{things_not_to_be_escaped}.
\begin{DoxyCode}
17 This is some code that contains an_underscore and
18 an escaped\_underscore. Plus another unescaped_underscore
19 for good measure.
20 As if that was not ""bad"" enough, it also contains a \%percent sign
21 that is escaped.
\end{DoxyCode}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}