$re = '/(?<=begin{DoxyCode})([\s\S]+?[^\\\\])([_%])([\s\S]+?)(?=end{DoxyCode})/';
$str = '\\begin{DoxyCode}
17 This is some code that contains an_undersc_ore and
18 an escaped\\_underscore. Plus another unescaped_unders_core
19 for good measure.
20 As if that was not "bad" enough, it also contains a %percent sign
21 that is unescaped.
\\end{DoxyCode}
Here is some other stuff that may contain \\index{things_not_to_be_escaped}.
\\begin{DoxyCode}
17 This is some code that contains an_underscore and
18 an escaped\\_underscore. Plus another unescaped_underscore
19 for good measure.
20 As if that was not "bad" enough, it also contains a \\%percent sign
21 that is escaped.
\\end{DoxyCode}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);