# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=begin{DoxyCode})([\s\S]+?[^\\])([_%])([\s\S]+?)(?=end{DoxyCode})"
test_str = ("\\begin{DoxyCode}\n"
"17 This is some code that contains an_undersc_ore and \n"
"18 an escaped\\_underscore. Plus another unescaped_unders_core \n"
"19 for good measure. \n"
"20 As if that was not \"bad\" enough, it also contains a %percent sign\n"
"21 that is unescaped.\n"
"\\end{DoxyCode}\n\n"
"Here is some other stuff that may contain \\index{things_not_to_be_escaped}.\n\n"
"\\begin{DoxyCode}\n"
"17 This is some code that contains an_underscore and \n"
"18 an escaped\\_underscore. Plus another unescaped_underscore \n"
"19 for good measure. \n"
"20 As if that was not \"bad\" enough, it also contains a \\%percent sign\n"
"21 that is escaped.\n"
"\\end{DoxyCode}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.