use strict;
my $str = '\\begin{DoxyCode}
17 This is some code that contains an_undersc_ore and
18 an escaped\\_underscore. Plus another unescaped_unders_core
19 for good measure.
20 As if that was not "bad" enough, it also contains a %percent sign
21 that is unescaped.
\\end{DoxyCode}
Here is some other stuff that may contain \\index{things_not_to_be_escaped}.
\\begin{DoxyCode}
17 This is some code that contains an_underscore and
18 an escaped\\_underscore. Plus another unescaped_underscore
19 for good measure.
20 As if that was not "bad" enough, it also contains a \\%percent sign
21 that is escaped.
\\end{DoxyCode}';
my $regex = qr/(?<=begin{DoxyCode})([\s\S]+?[^\\])([_%])([\s\S]+?)(?=end{DoxyCode})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}