import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=begin\\{DoxyCode\\})([\\s\\S]+?[^\\\\])([_%])([\\s\\S]+?)(?=end\\{DoxyCode\\})";
final String string = "\\begin{DoxyCode}\n"
+ "17 This is some code that contains an_undersc_ore and \n"
+ "18 an escaped\\_underscore. Plus another unescaped_unders_core \n"
+ "19 for good measure. \n"
+ "20 As if that was not \"bad\" enough, it also contains a %percent sign\n"
+ "21 that is unescaped.\n"
+ "\\end{DoxyCode}\n\n"
+ "Here is some other stuff that may contain \\index{things_not_to_be_escaped}.\n\n"
+ "\\begin{DoxyCode}\n"
+ "17 This is some code that contains an_underscore and \n"
+ "18 an escaped\\_underscore. Plus another unescaped_underscore \n"
+ "19 for good measure. \n"
+ "20 As if that was not \"bad\" enough, it also contains a \\%percent sign\n"
+ "21 that is escaped.\n"
+ "\\end{DoxyCode}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}