package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_-]+$`)
var str = `gamertag
GamerTag
Gamer_Tag
_GamerTag
GamerTag_-
GamerTag
Gamer-Tag
GamerTag-
!GamerTag
Gamer%Tag
Gamer Tag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}