$re = '/^[a-zA-Z0-9_-]+$/m';
$str = 'gamertag
GamerTag
Gamer_Tag
_GamerTag
GamerTag_-
GamerTag
Gamer-Tag
GamerTag-
!GamerTag
Gamer%Tag
Gamer Tag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);